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Step 1. Set up page orientation and page size 

 

How to set up page orientation and page size 

PowerPoint is setup by default to produce slides for a slideshow presentation. So the first thing you 
need to do is to create a new blank presentation and change the page set up for an A1 or A0 size 
poster in either portrait or landscape orientation. 

Create a blank presentation with a blank slide layout 

1. From the File menu, click on New  
2. From the New Presentation task pane select Blank presentation  

 

1. Then select the Blank presentation layout.  

 

You now have a clean canvas to start designing your poster. 
The next thing you have to do is to set up page size and orientation. 
What size is your poster going be, A0 or A1? 
What orientation will it be? Portrait or Landscape? 

Set up the poster for size A0 Landscape 

1. From the File menu, select Page Setup.  
2. Under Slides Sized for, select Custom.  



3. Check that the Width and Height units are set to cms. 
For an A0 poster  

4. In the Width box, type in 118.9  
5. In the Height box, type in 84.1 

Poster dimensions  

A0  
 

A1  
 

A2  
 

A3  
 

118.9 x 84.1  
 

84.1 x 59.4  
 

59.4 x 42 
 

42 x 29.7 
 

6. Under Orientation check that it's set to Landscape 
7. Click on OK and save the file  
8. To maximise the area of screen for your poster, close the Task pane and the Slide pane  

Notice that you are currently viewing the poster at 17% of its original size. 
Finally another few things to check: 

 Select the View menu, select Toolbars and make sure you have drawing toolbar, 
formatting palette and slide view selected.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Step 2. Grids and Guides 

 

How to add grids and guides 

In order to accurately place text and graphics you need to use the grids and guides tool. 

Grids are dotted vertical and horizontal lines that appear on the page to help you position objects, 
they help you to judge the distance between objects on your poster (don't worry grid lines won't 
appear on your printed poster). 

Guides are vertical and horizontal lines that you can use to help line up text and graphics 

This page shows you how to: 

 Display grids and guides  
 Display the ruler  
 Create more drawing guides  

The following instructions will show you how to display the grid, add guides for margins at each edge, 
for columns and for a text area. You will also learn how to display the ruler. 

Display grids and  guides 

1. To view the grid, from the View menu, choose Grid and Guides.  
2. In the Grid and Guides dialog box, make sure that Snap objects to grid is selected.  
3. Change to 2 grids per cm (you can always modify this later if you wnat greater control).  
4. Click on the box Display grid on screen.  
5. Click on the box Display drawing guides on screen.  
6. Then click on OK.  

 

Your PowerPoint poster will show a grid of dots, with two lines which dissect the poster in the centre. 
These two lines are the drawing guides which will help you to place objects (text and pictures) on your 
poster. 



Display the ruler 

First of all you are going to add a ruler, from the View menu select Ruler. 

A horizontal ruler appears across the top of the poster and a vertical ruler along the left side of the 
poster. 

Notice that the zero point for each ruler is at the centre of each ruler. You will measure things from the 
centre of your poster. 
Next you'll create guides to help you create a poster with a four column layout with the title of the 
poster across the top. You want to make sure the poster has plenty of white space and you will have 
at least 3 cms of white space between columns and each column will be 26 cms wide. 

Create more drawing guides 

 
 

 To create a new guide, press Ctrl while dragging on a guideline.  

To create guides to help you make a poster with a four column layout, with 3cms of white space 
between columns: 

1. First create two vertical guide each 1.5cms left and right  from the centre.  
2. Next create six vertical guides, 27.5 cms, 30.5, 56.5, left and right from the centre.  
3. Note that you are only allowed to create 8 horizontal and 8 vertical guides.  
4. Create three horizontal guides at the top of the poster 28 cms, 30 cms and 40 cms from the 

centre and one along the bottom at 36 cms from the centre.  

According to design principles, the bottom margin should be slightly bigger than the top margin. 

These guides will help you place text and images on a poster with a four column layout. 

Print Margins: All printers have an area at the edge of the paper that they can't print on. These are 
called print margins (they differ slightly from printer to printer). To be on the safe side, don't put 
objects within 2 cms of the edge of the paper. 
  

 



Step 3. Add text boxes 

 

How to add and edit text 

Once you have set up grids and guides and designed a layout that will help people read the 
information on your poster, the next step is to add content to your poster. 
This page covers how to: add a tilte banner, add headings and add main content. It explains how to: 

 Add and modify a text box  
 Copy and paste text from Word  
 Change font size and style  
 Change line spacing  
 Change paragraph alignment  

Add a title banner to your poster 

You add text to your poster by adding a text box, you can then either type in text or copy in text from 
MS Word. 

First of all, you are going to add a text box for the title of the poster 

The title usually goes across the top of the entire poster, with the content arranged under it columns. 
The information is normally read from the upper left read corner, down each column to the lower right 
corner. 

1. On the drawing toolbar at the bottom of the screen click in the text box tool (if you can't see 
the drawing toolbar, go to the View menu and select Toolbars: Drawing.)  
 

 
 
 

2. Drag a text box approximately where you want it at the top of your poster (you can adjust this 
later).  

3. Type in the content: e.g Title of poster, Names of contributors, date.  

Next, you are going to change the format and alignment of the text 

This is how you change the font of the title to Arial in a larger font size. 

1. To change the text for the Poster title select the Title text, go to the Format menu and select 
Font and select Arial and change the font size (minimum 72pt), then select the second line of 
text (names of contributors etc), change the font to Arial and the font size (minimum 50pt).  

2. To centre the text, select the text and click on the Centre alignment button.  

If you want to change the background colour... 

1. Make sure the text box is selected, then from the Format menu, click on Text box.  



2. In the Fill and color tab, under Fill click on the arrow next to Color and choose a colour.  

To change the colour of the font... 

1. Highlight the text, select Format Font and choose a font colour.  

To add more white space... 

If you want to add more white space so the text is not right up against the edge of the border of the 
text box. 

The more white space you have around your text, the more legible it will be. 

1. Select the text box and the from the Format menu select Text box.  
2. Click on the Text box tab, and then change the internal margins to 1 cm and make sure that 

Word Wrap is selected.  

To change the height of the text box to 10 cms.. 

1. Select the text box and the from the Format menu select Text box.  
2. Click on the Size tab, and in the height box, type in 10.  

Show me how to create a title banner 

Add a text box for a heading 

1. On the drawing toolbar at the bottom of the screen click in the text box tool  
2. Drag a text box approximately where you want it on your poster (you can adjust this later).  
3. Type in the content  
4. Change the font to Arial in font size 40 pt  
5. Change the background colour to grey  
6. Change the font to white  
7. Change the margins to 0.5 cms. In the Format Text box dialog box, click on the Text box 

tab, and then change the internal margins to 0.5 cms and make sure that Word Wrap is 
selected.  

 



To create another text box.. 
Now that you have created a text box that is the exact width you need for your poster and the text and 
internal margins are set as you want them, the easiest way to create another text box is just to copy 
the one you have just created and replace the text. 

Add a text box for some text in the first column 

1. Draw a text box approximately where you want it, in the first column of your poster ( we will 
adjust this later)  

2. Type in the content  
3. Your main text will be easier to read in a Serif font e.g. Times New Roman. Change the font 

to Times New Roman in 32p ( minimum of 22pt)  
4. Change the margins to 0.5 cm  
5. To make these settings the default, select the Colors and Lines tab, and select Default for 

new objects  
6. To resize the text box, place the cursor in a selection handle and drag until it is the required 

size  
7. To move a text box, click on the text box, place the cursor on the text box, it should change to 

a four way arrow. You can now drag the text box to a different position.  

 

 

 

 

 

 

 

 

 

 



Step 4. Using the Zoom tool 

How to use the Zoom tool 

You will probably want to work on your poster at different magnifications or reductions depending on 
whether you want to see the entire poster or just one section of it. You can zoom in to see the detail of 
text and other objects and zoom out to see the whole poster. 

If you are working on the layout and you want to see the entire poster, use the Zoom tool to fit the 
poster to the screen 

To see the entire poster 

 From the View menu, select Zoom and then select Fit.  

To zoom into one section of the poster 

If you are working on the text of a particular section, it might be easier to see the text if you zoom into 
that section. 

1. Click in the area you want to zoom into.  
2. From the View menu, select Zoom, and then select 33%.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Step 5. Insert images 

 

How to insert and modify images 

Before you insert images (such as photographs and diagrams) into your poster, it is recommended 
that you use Photo editing software such as Photoshop or Gimp to change them to an appropriate 
size and format. 

For example you need to consider: 

 The resolution: should be high enough to print clearly - e.g. 300 dpi (minimum 150 dpi)  
 The dimensions: approximately the length and width required (you can if needed tweak this 

in PowerPoint later).  
 Size in megabytes: by setting the resolution to between 150 and 300 dpi and the dimensions 

to the actual size you need, you will keep file sizes to an optimum level.  
 File Format of the photograph file: we recommend a tiff format (for optimal printing) but you 

can use jpeg or png for photographs and gif or png for drawings, graphs and clipart (these are 
compressed formats).  

A few tips..... 

 Don't use images taken from the web. Images on web pages are of very low resolution (72 
dpi), and if enlarged will pixilate, and not print clearly. Images created for the web are not 
recommended for poster presentations.  

 Once you have prepared your pictures, check to see how they print out at the required size. 
Are they still sharp and in focus?  

 Save all your pictures in one folder, so you can easily access them.  
 If you are scanning in images, scan them in at a high resolution (300 dpi) and scan them in at 

the size they will be printed out on your poster.  

Once you have selected and prepared the images for your poster, the next stage is to insert them into 
your poster. 

Insert an image 

1. From the Insert menu, select Picture and then From File.  
2. Navigate to find your picture, click on the filename to select it and then click on the Insert 

button  

You may then need to reposition it… 

1. Select the image, sizing handles should appear around the image.  
2. Position the cursor within the image, it should change to a four sided arrow, drag the image to 

its new position. 
If you hold down the Alt key while dragging the image you will be able to position it more 
precisely as it won't snap to position on the grid.  

To resize an image… 

 Move the cursor to one of the sizing handles at one of the corners and drag inwards or 
outwards to increase or decrease the size.  



Step 6. Align and distribute tool 

 

How to use the Align and Distribute tool 

You can use guides and rulers to help you align graphics on your poster or to space objects equally 
but there is a tool that will do this for you automatically. 

Let's say that you have 3 pictures you want to align to the bottom margin and to distribute them so 
that there is exactly the same space between them. 

To align two or more items vertically 

1. Click to select the first picture you want to align; hold down the shift key as you click on the 
other pictures.  

2. On the Drawing toolbar, click Draw: Align or Distribute: Align Bottom  

To distribute two or more items with equal space between them 

1. Click to select the first picture you want to space evenly; hold down the shift key as you click 
on the other pictures.  

2. On the Drawing toolbar, click Draw: Align or Distribute: distribute horizontally.  

Note: If you are trying to align items and they jump to the top or bottom of the screen, you may need 
to untick relative to slide. 

 

 

 

 

 

 

 

 

 

 

 

 



Step 7. Add tables, graphs and diagrams 

 

How to add tables, graphs and diagrams 

It is useful to have diagrams and graphs in your poster, it gives you something you can explain to your 
audience. Diagrams can be useful for showing processes and graphs for displaying numerical data. 

Diagrams - It is best to create your diagrams in another PowerPoint file or in another program and 
then copy and paste them into your poster. 

Tables - You can create tables in Word and then copy and paste them into your poster. 

Graphs - you can create your graphs in Excel. Before you add them to your poster it is important that 
you make sure that they are readable from a distance. Check that there is sufficient contrast between 
the lines and the background, remove the legend and add labels to the x and y axis. 

To insert a chart or graph from Excel or another application 

1. Select and copy the chart/graph from the program you used.  
2. In PowerPoint, in the Edit Menu, select Paste Special, then select Picture (Enhanced 

Metafile).  
3. Click on OK  

 
This imports the file in as a graphic file. It cannot be manipulated or changed because it is not linked 
to the original. If, on the other hand, you just paste a chart or graph directly into PowerPoint (not paste 
special), you can double click it and it will allow you to change data via the original application. When 
printed, however, the text tends to move around and the chart may change in appearance. A graphic 
file created by the "Paste Special" command is usually better for printing purposes. 

Once inserted into PowerPoint give the graph a title, a short informative title will help the viewer. 

 

 

 



Step 8. Add colours, borders and backgrounds 

 

How to add colours, borders and backgrounds 

Next we will look at how to add and change colours. 

 How to change colour of text  
 How to add colour to a text box  
 How to add a background colour  
 How to add a background picture  
 How to add a border  

It is recommended that you use a dark colour for text on a light background. The function of colours 
on your poster should be to help the reader to navigate the information, help distinguish between 
elements on your poster. 

Note that colours on your screen may look different in print; in general a colour will appear lighter on 
the screen than in print. 

A few tips... 

 It is important to have a colour scheme with two or three related colours.  
 Colours that are close together on a colour wheel look good together.  
 Use bright colours sparingly.  

Change colour of text 

 Click on the text box, select the text, and then from the Format menu select Font and choose 
a colour.  

Add background colour to a text box 

 Right mouse click on the text box, select Format text box. Make sure the Colours and Lines 
tab is selected, next to No Fill click on the arrow and choose a colour.  

Add a background colour to the poster 

 From the Format menu, select Background and choose a colour. Click on Apply.  

Show me how to add a background colour to the poster 

Add a background picture to the poster 

1. From the Format menu, select Background, and under the Background Fill box, click on 
the arrow and select Fill Effects.  

2. Then click on the Picture tab, click in Select Picture and navigate to the file you want to use 
as a background, click on Insert and then OK.  

3. Finally click on Apply.  



Note a faded picture makes a better background; otherwise the image will detract from the content. 

Add a border to the poster 

To add a rectangular border to your poster. 

The simplest way to a line border to your poster is to add a rectangle and remove its fill colour so that 
you just have a line. You can then modify the thickness and colour of this line. 

1. From the Drawing toolbar, click on the rectangle tool, drag the rectangle over the entire 
poster within the print margins.  

2. From the Format menu, select AutoShape, and under Fill: color: select Nofill.  
3. To change the thickness of the line, under Line: Weight, increase the point size (e.g. change 

to 10 pts)  
4. To change the colour of the line, under Line: Colour choose a different colour  

Add borders to a text box 

1. Right mouse click on the text box. Select Format text box.  
2. In the Line section, select a colour and a style for your line.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Step 9. Set up your poster for printing 

 

How to set up your poster for printing 

We recommend that you convert your poster file to a PDF format. The PDF will give you an clear idea 

what your poster will look like in print, will help you spot any problems and will give you a smaller file 

size. 

Create a PDF 

The following instructions show you how to convert your file to a pdf using Save As…. 

In PowerPoint: 

1. Select Save As form the File Menu.  
2. Select File Name text box and rename file. 
3. Select PDF from the Save As Type drop down menu. 
4. Click on the Options… button and untick ISO 19005-1 compliant (PDF/A) 
5. Click on the Okay button.  
6. Click on the Save button. 
7. Your file will be converted to a pdf format, this process may take a few minutes.  

 

See the IS Resource Centre printing instruction guides for more information 

 

 

 

 

 

 

 

 

 



The University King’s Buildings

King's Buildings Copy Centre

Opening times: Monday to Friday, 9am-5pm

King's Buildings Copy Centre
Room 2300, James Clerk Maxwell Building (JCMB)
King's Buildings
Edinburgh EH9 3JF
United Kingdom

Contact: Martin Byrne 
email: kbcopy@ed.ac.uk

Tel: +44 (0)131 650 5001
Fax: +44 (0)131 650 5821

Posters may be collected direct from the KB Copy Centre or sent to you via the internal mail (please
allow at least three working days after your poster is printed for it to reach you and give 
KB Copy Shop your name and address the poster is to be delivered to).
This service adds £3.00 to your EIT.
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